Name Description Size Coverage
moz.build 3212 -
TestAuthModuleInitAsync.cpp 4460 98 %
TestBase64Stream.cpp 3324 80 %
TestBind.cpp 5490 93 %
TestBufferedInputStream.cpp 7507 97 %
TestCacheControlParser.cpp 3169 100 %
TestCacheCrypto.cpp 8017 100 %
TestCacheEntryWriterHang.cpp 8756 100 %
TestCacheIndex.cpp 7309 95 %
TestCapsule.cpp 11037 100 %
TestCommon.cpp 280 100 %
TestCommon.h 1093 100 %
TestCookie.cpp shouldResistFingerprinting 67715 98 %
TestDNS.cpp aShouldReenter 9437 96 %
TestDNSPacket.cpp 2645 100 %
TestEtcHostsParsing.cpp 9726 100 %
TestHappyEyeballsConnectionAttempt.cpp 39480 85 %
TestHappyEyeballsNetAddrArray.cpp h1 4762 92 %
TestHeaders.cpp 4512 97 %
TestHostRecordQueue.cpp 3442 95 %
TestHttp2WebTransport.cpp 36749 95 %
TestHttp3ConnectUDPStream.cpp 14246 79 %
TestHttpAtom.cpp 1163 100 %
TestHttpAuthUtils.cpp 1293 100 %
TestHttpChannel.cpp 3614 79 %
TestHttpResponseHead.cpp 8232 99 %
TestHttpTransactionRestart.cpp caps 7997 100 %
TestIDNA.cpp 5455 100 %
TestInputStreamTransport.cpp 5305 72 %
TestIsValidIp.cpp 4612 100 %
TestLinkHeader.cpp 15168 79 %
TestLocalNetworkAccess.cpp --------------------------------------------------------------------------* | Network | Description | RFC | Scope | |----------------------|------------------------|-----------|------------------| 127.0.0.0/8 | IPv4 Loopback | RFC1122 | local | 10.0.0.0/8 | Private Use | RFC1918 | private | 100.64.0.0/10 | Carrier-Grade NAT | RFC6598 | private | 172.16.0.0/12 | Private Use | RFC1918 | private | 192.168.0.0/16 | Private Use | RFC1918 | private | 198.18.0.0/15 | Benchmarking | RFC2544 | pref/local 169.254.0.0/16 | Link Local | RFC3927 | private | ::1/128 | IPv6 Loopback | RFC4291 | local | fc00::/7 | Unique Local | RFC4193 | private | fe80::/10 | Link-Local Unicast | RFC4291 | private | ::ffff:0:0/96 | IPv4-mapped | RFC4291 | IPv4-mapped address space | -------------------------------------------------------------------------- 12327 95 %
TestMIMEInputStream.cpp 7066 94 %
TestMozURL.cpp 9392 100 %
TestNamedPipeService.cpp Unlike a monitor, an event allows a thread to wait on another thread completing an action without regard to ordering of the wait and the notify. 7808 63 %
TestNetworkLinkIdHashingDarwin.cpp 2709 -
TestNetworkLinkIdHashingWindows.cpp 2461 100 %
TestNoVarySearchUtils.cpp 11917 99 %
TestPACMan.cpp {FEBF1D69-4D7D-4891-9524-045AD18B5593} \ 7151 100 %
TestParseHeaders.cpp 6406 100 %
TestPollableEvent.cpp 1866 100 %
TestProtocolProxyService.cpp 8986 99 %
TestReadStreamToString.cpp 5632 100 %
TestSanitizedSpec.cpp 2666 95 %
TestServerTimingHeader.cpp 10250 100 %
TestSFV.cpp 9864 100 %
TestSocketTransportService.cpp 10439 94 %
TestSSLTokensCache.cpp 28936 96 %
TestStandardURL.cpp 24861 85 %
TestStorageAccessHeader.cpp 3446 100 %
TestSyncStreamListener.cpp 16078 90 %
TestUDPSocket.cpp UDPClientListener: listens for incomming UDP packets 11849 92 %
TestURIMutator.cpp 6928 100 %
TestUriTemplate.cpp 3310 100 %
TestUrlPatternGlue.cpp 30018 100 %
TestUseAsDictionary.cpp /main.js\""_ns, "/app/ 6398 100 %
TestWebTransportFlowControl.cpp 7874 100 %
urltestdata-orig.json 137437 -
urltestdata.json 192970 -