Name Description Size Coverage
moz.build 3134 -
TestBase64Stream.cpp 3324 0 %
TestBind.cpp 5490 0 %
TestBufferedInputStream.cpp 7507 0 %
TestCacheControlParser.cpp 3169 0 %
TestCacheCrypto.cpp 8017 100 %
TestCacheEntryWriterHang.cpp 8756 100 %
TestCacheIndex.cpp 7309 0 %
TestCapsule.cpp 11037 0 %
TestCommon.cpp 280 0 %
TestCommon.h 1093 0 %
TestCookie.cpp shouldResistFingerprinting 67715 0 %
TestDNS.cpp aShouldReenter 9437 0 %
TestDNSPacket.cpp 2645 0 %
TestEtcHostsParsing.cpp 9726 0 %
TestHappyEyeballsConnectionAttempt.cpp 39480 85 %
TestHappyEyeballsNetAddrArray.cpp h1 4762 92 %
TestHeaders.cpp 4512 0 %
TestHostRecordQueue.cpp 3442 0 %
TestHttp2WebTransport.cpp 36749 0 %
TestHttp3ConnectUDPStream.cpp 14246 0 %
TestHttpAtom.cpp 1163 0 %
TestHttpAuthUtils.cpp 1293 0 %
TestHttpChannel.cpp 3614 0 %
TestHttpResponseHead.cpp 8232 0 %
TestHttpTransactionRestart.cpp caps 7997 0 %
TestIDNA.cpp 5455 0 %
TestInputStreamTransport.cpp 5305 0 %
TestIsValidIp.cpp 4612 0 %
TestLinkHeader.cpp 15168 0 %
TestLocalNetworkAccess.cpp --------------------------------------------------------------------------* | Network | Description | RFC | Scope | |----------------------|------------------------|-----------|------------------| 127.0.0.0/8 | IPv4 Loopback | RFC1122 | local | 10.0.0.0/8 | Private Use | RFC1918 | private | 100.64.0.0/10 | Carrier-Grade NAT | RFC6598 | private | 172.16.0.0/12 | Private Use | RFC1918 | private | 192.168.0.0/16 | Private Use | RFC1918 | private | 198.18.0.0/15 | Benchmarking | RFC2544 | pref/local 169.254.0.0/16 | Link Local | RFC3927 | private | ::1/128 | IPv6 Loopback | RFC4291 | local | fc00::/7 | Unique Local | RFC4193 | private | fe80::/10 | Link-Local Unicast | RFC4291 | private | ::ffff:0:0/96 | IPv4-mapped | RFC4291 | IPv4-mapped address space | -------------------------------------------------------------------------- 12327 0 %
TestMIMEInputStream.cpp 7066 0 %
TestMozURL.cpp 9392 0 %
TestNamedPipeService.cpp Unlike a monitor, an event allows a thread to wait on another thread completing an action without regard to ordering of the wait and the notify. 7808 0 %
TestNetworkLinkIdHashingDarwin.cpp 2709 -
TestNetworkLinkIdHashingWindows.cpp 2461 0 %
TestNoVarySearchUtils.cpp 11917 0 %
TestPACMan.cpp {FEBF1D69-4D7D-4891-9524-045AD18B5593} \ 7151 0 %
TestParseHeaders.cpp 6406 0 %
TestPollableEvent.cpp 1866 0 %
TestProtocolProxyService.cpp 8986 0 %
TestReadStreamToString.cpp 5632 0 %
TestSanitizedSpec.cpp 2666 0 %
TestServerTimingHeader.cpp 10250 0 %
TestSFV.cpp 9864 0 %
TestSocketTransportService.cpp 10439 0 %
TestSSLTokensCache.cpp 28936 0 %
TestStandardURL.cpp 24861 0 %
TestStorageAccessHeader.cpp 3446 0 %
TestSyncStreamListener.cpp 16078 0 %
TestUDPSocket.cpp UDPClientListener: listens for incomming UDP packets 11849 0 %
TestURIMutator.cpp 6928 0 %
TestUriTemplate.cpp 3310 0 %
TestUrlPatternGlue.cpp 30018 0 %
TestUseAsDictionary.cpp /main.js\""_ns, "/app/ 6398 0 %
TestWebTransportFlowControl.cpp 7874 0 %
urltestdata-orig.json 137437 -
urltestdata.json 192970 -