Source code

Revision control

Other Tools

{
"data": [
{
"os": "Linux",
"schema": 1603099489080,
"details": {
"why": "Old versions of the Flash Player plugin have known vulnerabilities. All users are strongly recommended to check for updates <a href=\"https://get.adobe.com/flashplayer/\">on Adobe's Flash page</a>.",
"name": "Flash Player Plugin on Linux 32.0.0.443 and older (click-to-play)"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "32.0.0.443",
"minVersion": "0",
"vulnerabilityStatus": 1
}
],
"matchFilename": "libflashplayer\\.so",
"id": "49b843cc-a8fc-4ede-be0c-a0da56d0214f",
"last_modified": 1603126502200
},
{
"schema": 1603050119276,
"details": {
"why": "Old versions of the Flash Player plugin have known vulnerabilities. All users are strongly recommended to check for updates <a href=\"https://get.adobe.com/flashplayer/\">on Adobe's Flash page</a>.",
"name": "Flash Player Plugin 32.0.0.443 and older (click-to-play)"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "32.0.0.443",
"minVersion": "0",
"vulnerabilityStatus": 1
}
],
"matchFilename": "(NPSWF32.*\\.dll)|(NPSWF64.*\\.dll)|(Flash\\ Player\\.plugin)",
"id": "832dc9ff-3314-4df2-abcf-7bd65a645371",
"last_modified": 1603126502196
},
{
"schema": 1524072853593,
"details": {
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"https://java.com/\">java.com</a>.",
"name": "Java Plugin 8 update 76 to 170 (click-to-play), Windows"
},
"enabled": true,
"infoURL": "https://java.com/",
"matchName": "Java\\(TM\\) Platform SE 8 U(7[6-9]|[8-9]\\d|1([0-6]\\d|70))(\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "npjp2\\.dll",
"id": "33147281-45b2-487e-9fea-f66c6517252d",
"last_modified": 1524073129197
},
{
"schema": 1524072853593,
"details": {
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on <a href=\"https://java.com/\">java.com</a>.",
"name": "Java Plugin 8 update 76 to 170 (click-to-play), Linux"
},
"enabled": true,
"infoURL": "https://java.com/",
"matchName": "Java(\\(TM\\))? Plug-in 11\\.(7[6-9]|[8-9]\\d|1([0-6]\\d|70))(\\.\\d+)?([^\\d\\._]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "libnpjp2\\.so",
"id": "ab59635e-2e93-423a-9d57-871dde8ae675",
"last_modified": 1524073076276
},
{
"schema": 1524068554047,
"details": {
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on <a href=\"https://java.com/\">java.com</a>.",
"name": "Java Plugin 8 update 170 and lower (click-to-play), Mac OS X"
},
"enabled": true,
"infoURL": "https://java.com/",
"versionRange": [
{
"severity": 0,
"maxVersion": "Java 8 Update 170",
"minVersion": "Java 8 Update",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "JavaAppletPlugin\\.plugin",
"id": "f24ffd6f-e02b-4cf4-91d9-d54cd793e4bf",
"last_modified": 1524072853584
},
{
"schema": 1519390914958,
"details": {
"who": "All users who have these versions of the plugin installed.",
"why": "Old versions of the Adobe Reader plugin have known vulnerabilities. All users are strongly recommended to check for updates <a href=\"https://get.adobe.com/reader/\">on Adobe's Reader page</a>.",
"name": "Adobe Reader XI 11.0.18 and lower"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "11.0.18",
"minVersion": "11.0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "(nppdf32\\.dll)|(AdobePDFViewerNPAPI\\.plugin)",
"id": "59c31ade-88d6-4b22-8601-5316f82e3977",
"last_modified": 1519390923381
},
{
"schema": 1519390914958,
"details": {
"who": "All users who have these versions of the plugin installed.",
"why": "Old versions of the Adobe Reader plugin have known vulnerabilities. All users are strongly recommended to check for updates <a href=\"https://get.adobe.com/reader/\">on Adobe's Reader page</a>.",
"name": "Adobe Reader 15.006.30244 and lower"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "15.006.30244",
"minVersion": "15.006",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "(nppdf32\\.dll)|(AdobePDFViewerNPAPI\\.plugin)",
"id": "3f136e56-4c93-4619-8c0d-d86258c1065d",
"last_modified": 1519390923357
},
{
"schema": 1519390914958,
"details": {
"who": "All users who have these versions of the plugin installed.",
"why": "Old versions of the Adobe Reader plugin have known vulnerabilities. All users are strongly recommended to check for updates <a href=\"https://get.adobe.com/reader/\">on Adobe's Reader page</a>.",
"name": "Adobe Reader 15.020.20042 and lower"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "15.020.20042",
"minVersion": "15.020",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "(nppdf32\\.dll)|(AdobePDFViewerNPAPI\\.plugin)",
"id": "43b45ad8-a373-42c1-89c6-64e2746885e5",
"last_modified": 1519390923333
},
{
"schema": 1519390914958,
"details": {
"why": "Old versions of this plugin have critical security vulnerabilities. You can update your plugin on <a href=\"https://get.adobe.com/shockwave/\">Adobe's website</a>.",
"name": "Adobe Shockwave for Director, version 12.2.7.197"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "12.2.7.197",
"minVersion": "0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "np32dsw_1227197\\.dll",
"id": "97647cd8-03c5-416c-b9d3-cd5ef87ab39f",
"last_modified": 1519390923310
},
{
"schema": 1519390914958,
"details": {
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on <a href=\"https://java.com/\">java.com</a>.",
"name": "Java Plugin 7 update 97 to 150 (click-to-play), Mac OS X"
},
"enabled": true,
"infoURL": "https://java.com/",
"versionRange": [
{
"severity": 0,
"maxVersion": "Java 7 Update 150",
"minVersion": "Java 7 Update 97",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "JavaAppletPlugin\\.plugin",
"id": "d70fdf87-0441-479c-833f-2213b769eb40",
"last_modified": 1519390923286
},
{
"schema": 1519390914958,
"details": {
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"https://java.com/\">java.com</a>.",
"name": "Java Plugin 7 update 97 to 150 (click-to-play), Windows"
},
"enabled": true,
"infoURL": "https://java.com/",
"matchName": "Java\\(TM\\) Platform SE 7 U(97|98|99|1([0-4][0-9]|50))(\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "npjp2\\.dll",
"id": "427f5ec6-d1a7-4725-ac29-d5c5e51de537",
"last_modified": 1519390923263
},
{
"schema": 1519390914958,
"details": {
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on <a href=\"https://java.com/\">java.com</a>.",
"name": "Java Plugin 7 update 97 to 150 (click-to-play), Linux"
},
"enabled": true,
"infoURL": "https://java.com/",
"matchName": "Java(\\(TM\\))? Plug-in 10\\.(97|98|99|1([0-4]\\d|50))(\\.\\d+)?([^\\d\\._]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "libnpjp2\\.so",
"id": "fdc40de3-95ab-41a5-94cf-9b400221a713",
"last_modified": 1519390923239
},
{
"schema": 1519390914958,
"blockID": "p416",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 6 updates 42 to 45 (click-to-play), Mac OS X",
"created": "2013-06-28T12:44:58Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "Java 6 Update 45",
"minVersion": "Java 6 Update 42",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "JavaAppletPlugin\\.plugin",
"id": "02a5865d-f6ea-a330-674e-7dea7390680f",
"last_modified": 1519390921640
},
{
"schema": 1519390914958,
"blockID": "p119",
"details": {
"who": "All Firefox users who have installed the Java plugin, JRE versions below 1.6.0_33 or between 1.7.0 and 1.7.0_4.",
"why": "Outdated versions of the Java plugin are vulnerable to an actively exploited security issue. All users are strongly encouraged to <a href=\"http://java.com/inc/BrowserRedirect1.jsp\">update their Java plugin</a>. For more information, please <a href=\"http://blog.mozilla.org/addons/2012/08/14/new-java-blocklist/\">read our blog post</a> or <a href=\"http://www.oracle.com/technetwork/topics/security/javacpujun2012-1515912.html\">Oracle's Advisory</a>.",
"name": "Java Plugin",
"created": "2012-08-14T09:27:32Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Plug-in 1\\.(6\\.0_(\\d|[0-2]\\d?|3[0-2])|7\\.0(_0?([1-4]))?)([^\\d\\._]|$)",
"versionRange": [
{
"severity": 1,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0.1"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "2.14.*",
"minVersion": "0.1"
}
]
}
],
"matchFilename": "libnpjp2\\.so",
"id": "d1aa9366-d40b-a68d-b3ed-4b36e4939442",
"last_modified": 1519390921616
},
{
"schema": 1519390914958,
"blockID": "p328",
"details": {
"who": "All Firefox users who have these versions of the plugin installed.",
"why": "Old versions of this plugin are potentially insecure and unstable. All affected users should visit the <a href=\"http://www.mozilla.com/plugincheck/\">plugin check</a> page to look for updates for their Silverlight plugin.",
"name": "Silverlight for Mac OS X between 5.1 and 5.1.20124.* (click-to-play)",
"created": "2013-03-26T09:35:05Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "5.1.20124.9999",
"minVersion": "5.1",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "19.0a1"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.16a1"
},
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0.4"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "Silverlight\\.plugin",
"id": "dd81b232-09cb-e31d-ed8b-c5cc6ea28dd0",
"last_modified": 1519390921592
},
{
"schema": 1519390914958,
"blockID": "p210",
"details": {
"who": "All Firefox users who have the Java 7 plugin, updates 7 and below.",
"why": "The Java 7 Runtime Environment, update version 7, has a <a href=\"http://www.oracle.com/technetwork/topics/security/javacpuoct2012-1515924.html\">serious security vulnerability</a> that is fixed in the latest update. All Firefox users are strongly encouraged to update as soon as possible. This can be done on the <a href=\"http://www.mozilla.com/plugincheck/\">Plugin Check</a> page.",
"name": "Java Plugin 1.7u7 (Linux)",
"created": "2012-11-22T09:31:33Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Plug-in 1\\.7\\.0(_0?7)?([^\\d\\._]|$)",
"versionRange": [
{
"severity": 1,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0.1"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "2.14.*",
"minVersion": "0.1"
}
]
}
],
"matchFilename": "libnpjp2\\.so",
"id": "8e562dba-7ae7-fa85-2c31-479c4e661056",
"last_modified": 1519390921568
},
{
"schema": 1519390914958,
"blockID": "p214",
"details": {
"who": "All Firefox users who have the Java 7 plugin, updates 7 and below.",
"why": "The Java 7 Runtime Environment, update version 7 and below, has a <a href=\"http://www.oracle.com/technetwork/topics/security/javacpuoct2012-1515924.html\">serious security vulnerability</a> that is fixed in the latest update. All Firefox users are strongly encouraged to update as soon as possible. This can be done on the <a href=\"http://www.mozilla.com/plugincheck/\">Plugin Check</a> page.",
"name": "Java Plugin 1.7u7 (Windows)",
"created": "2012-11-22T09:34:13Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Platform SE 7 U7(\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 1,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0.1"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "2.14.*",
"minVersion": "0.1"
}
]
}
],
"matchFilename": "npjp2\\.dll",
"id": "524ff62f-9564-a2b2-2585-88b88ea4c2f9",
"last_modified": 1519390921544
},
{
"schema": 1519390914958,
"blockID": "p414",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 6 updates 42 to 45 (click-to-play), Windows",
"created": "2013-06-28T12:43:43Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Platform SE 6 U4[2-5](\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "npjp2\\.dll",
"id": "e36516a6-8bb3-09cc-02e3-72c67046b42e",
"last_modified": 1519390921520
},
{
"schema": 1519390914958,
"blockID": "p184",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox 17 and above.",
"why": "The Java plugin is causing significant security problems. All users are strongly recommended to keep the plugin disabled unless necessary.",
"name": "Java Plugin 7 update 11 and lower (click-to-play), Linux",
"created": "2012-10-30T14:39:15Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Plug-in 1\\.7\\.0(_0?([0-9]|(1[0-1]))?)?([^\\d\\._]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "libnpjp2\\.so",
"id": "06621403-39a8-3867-ba6e-406dc20c88af",
"last_modified": 1519390921496
},
{
"schema": 1519390914958,
"blockID": "p412",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 6 updates 42 to 45 (click-to-play), Linux",
"created": "2013-06-28T12:42:20Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Plug-in 1\\.6\\.0_4[2-5]([^\\d\\._]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "libnpjp2\\.so",
"id": "8f652c63-cda4-1640-0b0c-23025e336b20",
"last_modified": 1519390921472
},
{
"schema": 1519390914958,
"blockID": "p29",
"details": {
"who": "Users of all versions of Yahoo Application State Plugin for Firefox 3 and later.\r\n\r\nUsers of all versions of Yahoo Application State Plugin for SeaMonkey 1.0.0.5 and later.",
"why": "This plugin causes a high volume of Firefox and SeaMonkey crashes.",
"name": "Yahoo Application State Plugin (SeaMonkey)",
"created": "2011-03-31T16:28:26Z"
},
"enabled": true,
"matchName": "^Yahoo Application State Plugin$",
"versionRange": [
{
"targetApplication": [
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "1.0.0.5"
}
]
}
],
"matchFilename": "npYState.dll",
"matchDescription": "^Yahoo Application State Plugin$",
"id": "8f52a562-5438-731b-5c64-7f76009f1489",
"last_modified": 1519390921448
},
{
"schema": 1519390914958,
"blockID": "p138",
"details": {
"who": "All Firefox users who have the Java 7 plugin, update 6 and below.",
"why": "The Java 7 Runtime Environment, update versions 6 and below, has a <a href=\"https://blog.mozilla.org/security/2012/08/28/protecting-users-against-java-security-vulnerability/\">serious security vulnerability</a> that is fixed in the latest update. All Firefox users are strongly encouraged to update as soon as possible. This can be done on the <a href=\"http://www.mozilla.com/plugincheck/\">Plugin Check</a> page.",
"name": "Java Plugin",
"created": "2012-09-13T14:49:52Z"
},
"enabled": true,
"versionRange": [
{
"severity": 1,
"maxVersion": "Java 7 Update 06",
"minVersion": "Java 7 Update 01",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0.1"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "2.14.*",
"minVersion": "0.1"
}
]
}
],
"matchFilename": "JavaAppletPlugin\\.plugin",
"id": "5e898a46-8ea9-2fab-5dfe-a43e51641d81",
"last_modified": 1519390921424
},
{
"schema": 1519390914958,
"blockID": "p457",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 7 update 25 to 44 (click-to-play), Linux",
"created": "2013-10-16T16:28:58Z"
},
"enabled": true,
"matchName": "Java(\\(TM\\))? Plug-in ((1\\.7\\.0_(2[5-9]|3\\d|4[0-4]))|(10\\.4[0-4](\\.[0-9]+)?))([^\\d\\._]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "libnpjp2\\.so",
"id": "5ca97332-f4b7-81f5-d441-6acb1834f332",
"last_modified": 1519390921400
},
{
"schema": 1519390914958,
"blockID": "p294",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 7 update 12 to 15 (click-to-play), Windows",
"created": "2013-02-25T12:33:48Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Platform SE 7 U1[2-5](\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "npjp2\\.dll",
"id": "ab8aff96-ead4-615d-be44-bcb7c31699f0",
"last_modified": 1519390921376
},
{
"schema": 1519390914958,
"blockID": "p186",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox 17 and above.",
"why": "The Java plugin is causing significant security problems. All users are strongly recommended to keep the plugin disabled unless necessary.",
"name": "Java Plugin 6 updates 31 through 38 (click-to-play), Windows",
"created": "2012-10-30T14:45:39Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Platform SE 6 U3[1-8](\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "npjp2\\.dll",
"id": "8488cdb0-1f00-1349-abfc-f50e85c9163b",
"last_modified": 1519390921351
},
{
"os": "Darwin",
"schema": 1519390914958,
"blockID": "p242",
"details": {
"who": "All Firefox (18 and above) users on Mac OS X who have installed a version of Flip4Mac older than 2.4.4.",
"why": "Old versions of the Flip4Mac WMV plugin are causing significant stability problems in Firefox 18 and above. Users are encouraged update to the latest version of the plugin, available at <a href=\"http://www.telestream.net/flip4mac/overview.htm\">the Flip4Mac site</a>.",
"name": "Flip4Mac WMV Plugin",
"created": "2012-12-21T13:32:36Z"
},
"enabled": true,
"versionRange": [
{
"severity": 1,
"maxVersion": "2.4.3.999",
"minVersion": "0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "18.0a1"
}
]
}
],
"matchDescription": "Flip4Mac",
"id": "cef6f402-bdf8-0ba6-66d8-8ac42c72d4be",
"last_modified": 1519390921327
},
{
"schema": 1519390914958,
"blockID": "p26",
"details": {
"who": "Users of all versions of Yahoo Application State Plugin for Firefox 3 and later.\r\n\r\nUsers of all versions of Yahoo Application State Plugin for SeaMonkey 1.0.0.5 and later.",
"why": "This plugin causes a high volume of Firefox and SeaMonkey crashes.",
"name": "Yahoo Application State Plugin",
"created": "2011-03-31T16:28:26Z"
},
"enabled": true,
"matchName": "^Yahoo Application State Plugin$",
"versionRange": [
{
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "3.0a1"
}
]
}
],
"matchFilename": "npYState.dll",
"matchDescription": "^Yahoo Application State Plugin$",
"id": "6a1b6dfe-f463-3061-e8f8-6e896ccf2a8a",
"last_modified": 1519390921303
},
{
"schema": 1519390914958,
"blockID": "p459",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 7 update 25 to 44 (click-to-play), Mac OS X",
"created": "2013-10-16T16:29:27Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "Java 7 Update 44",
"minVersion": "Java 7 Update 25",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "JavaAppletPlugin\\.plugin",
"id": "5b0bbf0e-dbae-7896-3c31-c6cb7a74e6fa",
"last_modified": 1519390921278
},
{
"schema": 1519390914958,
"blockID": "p188",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox 17 and above.",
"why": "The Java plugin is causing significant security problems. All users are strongly recommended to keep the plugin disabled unless necessary.",
"name": "Java Plugin 6 updates 38 and lower (click-to-play), Mac OS X",
"created": "2012-10-30T14:48:54Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "Java 6 Update 38",
"minVersion": "Java 6 Update 0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "JavaAppletPlugin\\.plugin",
"id": "61944828-8178-71ab-e9c6-d846b5f45d96",
"last_modified": 1519390921253
},
{
"schema": 1519390914958,
"blockID": "p292",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 7 update 12 to 15 (click-to-play), Mac OS X",
"created": "2013-02-25T12:32:41Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "Java 7 Update 15",
"minVersion": "Java 7 Update 12",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "JavaAppletPlugin\\.plugin",
"id": "9a09fe22-c3d8-57e6-4e99-ecd06fb03081",
"last_modified": 1519390921228
},
{
"schema": 1519390914958,
"blockID": "p125",
"details": {
"who": "All Firefox users who have installed the Java plugin, JRE versions below 1.6.0_33 or between 1.7.0 and 1.7.0_4.",
"why": "Outdated versions of the Java plugin are vulnerable to an actively exploited security issue. All users are strongly encouraged to <a href=\"http://java.com/inc/BrowserRedirect1.jsp\">update their Java plugin</a>. For more information, please <a href=\"http://blog.mozilla.org/addons/2012/08/14/new-java-blocklist/\">read our blog post</a> or <a href=\"http://www.oracle.com/technetwork/topics/security/javacpujun2012-1515912.html\">Oracle's Advisory</a>.",
"name": "Java Plugin",
"created": "2012-08-14T09:31:17Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Platform SE ((6( U(\\d|([0-2]\\d)|3[0-2]))?)|(7(\\sU[0-4])?))(\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 1,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0.1"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "2.14.*",
"minVersion": "0.1"
}
]
}
],
"matchFilename": "npjp2\\.dll",
"id": "7538347d-ca2e-09b8-c5d8-0a9d140f8c87",
"last_modified": 1519390921203
},
{
"schema": 1519390914958,
"blockID": "p134",
"details": {
"who": "All Firefox users who have the Java 7 plugin, update 6 and below.",
"why": "The Java 7 Runtime Environment, update versions 6 and below, has a <a href=\"https://blog.mozilla.org/security/2012/08/28/protecting-users-against-java-security-vulnerability/\">serious security vulnerability</a> that is fixed in the latest update. All Firefox users are strongly encouraged to update as soon as possible. This can be done on the <a href=\"http://www.mozilla.com/plugincheck/\">Plugin Check</a> page.",
"name": "Java Plugin",
"created": "2012-08-31T15:22:51Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Platform SE 7 U[5-6](\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 1,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0.1"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "2.14.*",
"minVersion": "0.1"
}
]
}
],
"matchFilename": "npjp2\\.dll",
"id": "1f519b98-a4b6-2a98-b1ff-b642f7b4d2bb",
"last_modified": 1519390921179
},
{
"schema": 1519390914958,
"blockID": "p123",
"details": {
"who": "All Firefox users who have installed the Java plugin, JRE versions below 1.6.0_33 or between 1.7.0 and 1.7.0_4.",
"why": "Outdated versions of the Java plugin are vulnerable to an actively exploited security issue. All users are strongly encouraged to <a href=\"http://java.com/inc/BrowserRedirect1.jsp\">update their Java plugin</a>. For more information, please <a href=\"http://blog.mozilla.org/addons/2012/08/14/new-java-blocklist/\">read our blog post</a> or <a href=\"http://www.oracle.com/technetwork/topics/security/javacpujun2012-1515912.html\">Oracle's Advisory</a>.",
"name": "Java Plugin",
"created": "2012-08-14T09:29:42Z"
},
"enabled": true,
"versionRange": [
{
"severity": 1,
"maxVersion": "14.2.0",
"minVersion": "0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0.1"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "2.14.*",
"minVersion": "0.1"
}
]
}
],
"matchFilename": "JavaPlugin2_NPAPI\\.plugin",
"id": "46bf36a7-1934-38f8-1fcc-c9c4bcc8343e",
"last_modified": 1519390921152
},
{
"schema": 1519390914958,
"blockID": "p190",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox 17 and above.",
"why": "The Java plugin is causing significant security problems. All users are strongly recommended to keep the plugin disabled unless necessary.",
"name": "Java Plugin 6 updates 31 through 38 (click-to-play), Linux",
"created": "2012-10-30T14:55:37Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Plug-in 1\\.6\\.0_3[1-8]([^\\d\\._]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "libnpjp2\\.so",
"id": "9f9eb0ae-6495-aaa6-041a-d802cdb8e134",
"last_modified": 1519390921128
},
{
"schema": 1519390914958,
"blockID": "p418",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 7 update 16 to 24 (click-to-play), Linux",
"created": "2013-06-28T12:46:18Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Plug-in 1\\.7\\.0_(1[6-9]|2[0-4])([^\\d\\._]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "libnpjp2\\.so",
"id": "ee5c1584-0170-8702-5f99-e0325b4a91a8",
"last_modified": 1519390921103
},
{
"schema": 1519390914958,
"blockID": "p182",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox 17 and above.",
"why": "The Java plugin is causing significant security problems. All users are strongly recommended to keep the plugin disabled unless necessary.",
"name": "Java Plugin 7 update 11 and lower (click-to-play), Windows",
"created": "2012-10-30T14:33:04Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Platform SE 7 U([0-9]|(1[0-1]))(\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "npjp2\\.dll",
"id": "385d9911-f8bc-83e0-8cd2-94c98087938c",
"last_modified": 1519390919419
},
{
"schema": 1519390914958,
"blockID": "p422",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 7 update 16 to 24 (click-to-play), Mac OS X",
"created": "2013-06-28T12:48:54Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "Java 7 Update 24",
"minVersion": "Java 7 Update 16",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "JavaAppletPlugin\\.plugin",
"id": "709960a7-d268-0c70-d6ad-17bbed0cd1c4",
"last_modified": 1519390919396
},
{
"schema": 1519390914958,
"blockID": "p212",
"details": {
"who": "All Firefox users who have the Java 7 plugin, updates 7 and below.",
"why": "The Java 7 Runtime Environment, update version 7, has a <a href=\"http://www.oracle.com/technetwork/topics/security/javacpuoct2012-1515924.html\">serious security vulnerability</a> that is fixed in the latest update. All Firefox users are strongly encouraged to update as soon as possible. This can be done on the <a href=\"http://www.mozilla.com/plugincheck/\">Plugin Check</a> page.",
"name": "Java Plugin 1.7u7 (Mac OS X)",
"created": "2012-11-22T09:33:07Z"
},
"enabled": true,
"versionRange": [
{
"severity": 1,
"maxVersion": "Java 7 Update 07",
"minVersion": "Java 7 Update 07",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0.1"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "2.14.*",
"minVersion": "0.1"
}
]
}
],
"matchFilename": "JavaAppletPlugin\\.plugin",
"id": "5ec1cd0f-d478-e6e0-989e-c91694b2a411",
"last_modified": 1519390919373
},
{
"schema": 1519390914958,
"blockID": "p302",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.\r\n",
"name": "Java Plugin 6 updates 39 to 41 (click-to-play), Linux",
"created": "2013-02-25T12:37:17Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Plug-in 1\\.6\\.0_(39|40|41)([^\\d\\._]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "libnpjp2\\.so",
"id": "caec8103-dec9-8018-eb3d-9cf21cbf68a6",
"last_modified": 1519390919350
},
{
"schema": 1519390914958,
"blockID": "p132",
"details": {
"who": "All Firefox users who have the Java 7 plugin, updates 6 and below.",
"why": "The Java 7 Runtime Environment, update versions 6 and below, has a <a href=\"https://blog.mozilla.org/security/2012/08/28/protecting-users-against-java-security-vulnerability/\">serious security vulnerability</a> that is fixed in the latest update. All Firefox users are strongly encouraged to update as soon as possible. This can be done on the <a href=\"http://www.mozilla.com/plugincheck/\">Plugin Check</a> page.",
"name": "Java Plugin",
"created": "2012-08-31T15:21:34Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Plug-in 1\\.7\\.0(_0?([5-6]))?([^\\d\\._]|$)",
"versionRange": [
{
"severity": 1,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0.1"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "2.14.*",
"minVersion": "0.1"
}
]
}
],
"matchFilename": "libnpjp2\\.so",
"id": "572d0485-3388-7c2a-a062-b062e42c8710",
"last_modified": 1519390919327
},
{
"schema": 1519390914958,
"blockID": "p296",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 7 update 12 to 15 (click-to-play), Linux",
"created": "2013-02-25T12:34:37Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Plug-in 1\\.7\\.0_1[2-5]([^\\d\\._]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "libnpjp2\\.so",
"id": "5b7aaf34-48a3-dfa5-1db8-550faef41501",
"last_modified": 1519390919304
},
{
"schema": 1519390914958,
"blockID": "p298",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.\r\n",
"name": "Java Plugin 6 updates 39 to 41 (click-to-play), Mac OS X",
"created": "2013-02-25T12:35:34Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "Java 6 Update 41",
"minVersion": "Java 6 Update 39",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "JavaAppletPlugin\\.plugin",
"id": "cfd76877-e79d-8e8c-c6a7-6b596fd344e8",
"last_modified": 1519390919281
},
{
"schema": 1519390914958,
"blockID": "p458",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 7 update 25 to 44 (click-to-play), Windows",
"created": "2013-10-16T16:29:18Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Platform SE 7 U(2[5-9]|3\\d|4[0-4])(\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "npjp2\\.dll",
"id": "d199d513-3c49-b53c-9447-33c8021c0df2",
"last_modified": 1519390919257
},
{
"schema": 1519390914958,
"blockID": "p420",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 7 update 16 to 24 (click-to-play), Windows",
"created": "2013-06-28T12:47:32Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Platform SE 7 U(1[6-9]|2[0-4])(\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "npjp2\\.dll",
"id": "5942b7ae-bcdc-e329-9f17-f7a795c9ec83",
"last_modified": 1519390919234
},
{
"schema": 1519390914958,
"blockID": "p254",
"details": {
"who": "All Firefox users on Mac OS X who are using the affected versions of the PDF Browser Plugin.",
"why": "The PDF Browser Plugin is causing frequent crashes on Firefox 18 and above. All users are recommended to keep the plugin disabled and update it if a new version becomes available.",
"name": "PDF Browser Plugin 2.4.2 and below",
"created": "2013-01-15T11:54:24Z"
},
"enabled": true,
"versionRange": [
{
"severity": 1,
"maxVersion": "2.4.2",
"minVersion": "0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "18.0a1"
}
]
}
],
"matchFilename": "PDF Browser Plugin\\.plugin",
"id": "2dd1b53a-52db-2d0f-392a-410d5aade9d6",
"last_modified": 1519390919211
},
{
"schema": 1519390914958,
"blockID": "p34",
"details": {
"who": "Users of Java 2 Plugin versions 1.5_00 to 1.6_99 in Firefox 3.6 and later.",
"why": "These versions of the Java plugin are no longer supported by Oracle and cause a high volume of Firefox crashes.",
"name": "Java Plugin",
"created": "2011-02-17T17:20:54Z"
},
"enabled": true,
"versionRange": [
{
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "3.6a1pre"
}
]
}
],
"matchFilename": "[Nn][Pp][Jj][Pp][Ii]1[56]0_[0-9]+\\.[Dd][Ll][Ll]",
"id": "91618232-c650-5dc6-00fe-293c0baedc34",
"last_modified": 1519390919188
},
{
"schema": 1519390914958,
"blockID": "p180",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox 17 and above.",
"why": "The Java plugin is causing significant security problems. All users are strongly recommended to keep the plugin disabled unless necessary.",
"name": "Java Plugin 7 update 10 and lower (click-to-play), Mac OS X",
"created": "2012-10-30T14:29:51Z"
},
"enabled": true,
"infoURL": "https://java.com/",
"versionRange": [
{
"severity": 0,
"maxVersion": "Java 7 Update 10",
"minVersion": "Java 7 Update 0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "JavaAppletPlugin\\.plugin",
"id": "12f38c07-c1e1-2464-2eab-d454cf471eab",
"last_modified": 1519390919165
},
{
"schema": 1519390914958,
"blockID": "p32",
"details": {
"who": "All users of the Viewpoint plugin for Firefox 3 and later.",
"why": "This plugin causes a high volume of Firefox crashes.",
"name": "Viewpoint",
"created": "2011-03-31T16:28:26Z"
},
"enabled": true,
"versionRange": [
{
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "3.0"
}
]
}
],
"matchFilename": "npViewpoint.dll",
"id": "1206e79a-4817-16e9-0f5e-7762a8d19216",
"last_modified": 1519390919142
},
{
"schema": 1519390914958,
"blockID": "p94",
"details": {
"who": "All Firefox users who have a version of the Flash Player Plugin older than 10.2.159.1.",
"why": "Old versions of the Flash Player plugin are targeted by known security vulnerabilities, and cause frequent Firefox crashes. We strongly recommend all users to visit <a href=\"http://get.adobe.com/flashplayer/\">the Flash Player homepage</a> to download and install the latest available version of this plugin.\r\n\r\nThis is not an ordinary block. It's just an upgrade notification that will be shown to all users who have these old versions installed, asking them to download the latest version. If they choose to ignore the notification, the plugin will continue to work normally.",
"name": "Flash Player Plugin",
"created": "2012-05-23T09:15:23Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "10.2.159.1",
"minVersion": "0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0.1"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "2.13.*",
"minVersion": "0"
}
]
}
],
"matchFilename": "Flash\\ Player\\.plugin",
"id": "2a741cac-32d7-a67e-0bf7-b5b53a0ff22b",
"last_modified": 1519390919119
},
{
"schema": 1519390914958,
"blockID": "p300",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 6 updates 39 to 41 (click-to-play), Windows",
"created": "2013-02-25T12:36:25Z"
},
"enabled": true,
"matchName": "Java\\(TM\\) Platform SE 6 U(39|40|41)(\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "17.0"
},
{
"guid": "{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}",
"maxVersion": "*",
"minVersion": "2.14"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "npjp2\\.dll",
"id": "d64e08b6-66b2-f534-53d8-1cbcbb139f2a",
"last_modified": 1519390919095
},
{
"schema": 1519390914958,
"blockID": "p152",
"details": {
"who": "All Firefox users who have this plugin installed.",
"why": "This plugin is outdated and is potentially insecure. Affected users should go to <a href=\"http://www.mozilla.com/plugincheck/\">the plugin check page</a> and update to the latest version.",
"name": "Silverlight 4.1.10328.0 and lower",
"created": "2012-10-05T10:34:12Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "4.1.10328.0",
"minVersion": "0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "npctrl\\.dll",
"id": "abdcbe90-5575-6b4b-12de-bbabd93ecf57",
"last_modified": 1519390919072
},
{
"schema": 1519390914958,
"blockID": "p904",
"details": {
"who": "All users who have these versions of the plugin installed in Firefox.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 8 update 44 and lower (click-to-play), Mac OS X",
"created": "2015-05-19T09:01:42Z"
},
"enabled": true,
"infoURL": "https://java.com/",
"versionRange": [
{
"severity": 0,
"maxVersion": "Java 8 Update 44",
"minVersion": "Java 8",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "JavaAppletPlugin\\.plugin",
"id": "47f6217d-0aa6-1e39-a9c9-cc64d57bb91f",
"last_modified": 1519390919049
},
{
"schema": 1519390914958,
"blockID": "p1061",
"details": {
"who": "All users who have these versions of the Java plugin installed.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 7 update 81 to 90 (click-to-play), Windows",
"created": "2015-12-02T12:39:41Z"
},
"enabled": true,
"infoURL": "https://java.com/",
"matchName": "Java\\(TM\\) Platform SE 7 U(8[1-9]|90)(\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "npjp2\\.dll",
"id": "69196ada-69bd-6454-eea8-6f8b2037368c",
"last_modified": 1519390919026
},
{
"schema": 1519390914958,
"blockID": "p1120",
"details": {
"who": "All users who have these versions of the Silverlight plugin installed.",
"why": "Old versions of the Silverlight plugin are known to have critical security vulnerabilities. You can get the latest version of Silverlight <a href=\"http://www.microsoft.com/getsilverlight/get-started/install/default.aspx\">here</a>.",
"name": "Silverlight plugin 5.1.41105.0 and lower (click to play)",
"created": "2016-02-03T09:42:43Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "5.1.41105.0",
"minVersion": "5.1.20125",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "(Silverlight\\.plugin|npctrl\\.dll)",
"id": "f0bfeb8c-04ee-d5ef-6670-b28c0e0d0f58",
"last_modified": 1519390919002
},
{
"schema": 1519390914958,
"blockID": "p102",
"details": {
"who": "All Firefox users who have this plugin installed.",
"why": "This plugin was discontinued years ago and only worked up to Firefox version 1.5. Because plugins aren't marked as incompatible, there are still many users who have it installed and have recently been experiencing crashes related to it.",
"name": "Mozilla ActiveX Plug-in",
"created": "2012-06-07T17:43:57Z"
},
"enabled": true,
"versionRange": [
{
"maxVersion": "*",
"minVersion": "0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
]
}
],
"matchFilename": "npmozax\\.dll",
"id": "2e001e2f-483b-7595-8810-3672e0346950",
"last_modified": 1519390918979
},
{
"os": "Darwin",
"schema": 1519390914958,
"blockID": "p252",
"details": {
"who": "All Firefox users on Mac OS X who have installed the Adobe Reader XI plugin. Users are recommended to update when a new version of Adobe Reader becomes available, or to downgrade to the latest version of Adobe Reader 10.",
"why": "The Adobe Reader XI plugin is causing frequent crashes on Firefox for Mac OS X. The impact and this block are currently limited to versions 11.0.0 and 11.0.01.",
"name": "Adobe Reader XI for Mac OS X",
"created": "2013-01-15T10:56:30Z"
},
"enabled": true,
"versionRange": [
{
"severity": 1,
"maxVersion": "11.0.01",
"minVersion": "11.0.0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
]
}
],
"matchFilename": "AdobePDFViewerNPAPI\\.plugin",
"id": "821ddb3d-bba4-6479-28b6-9974383fa8c9",
"last_modified": 1519390918955
},
{
"schema": 1519390914958,
"blockID": "p1004",
"details": {
"who": "All users who have these versions of the plugin installed",
"why": "These versions of the Unity Web Player plugin have known vulnerabilities that can put users at risk.",
"name": "Unity Web Player 5.0 to 5.0.3f1 (click-to-play), Mac OS",
"created": "2015-09-09T14:11:57Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "Unity Web Player\\.plugin",
"matchDescription": "^($|Unity Web Player version 5.0(\\.([0-2]|3f1))?[^0-9.])",
"id": "5a0b69cb-a516-e7a2-ea3b-b4fafcc13c6b",
"last_modified": 1519390918932
},
{
"schema": 1519390914958,
"blockID": "p248",
"details": {
"who": "All users who have Firefox 18 or above installed, and the Sibelius Scorch plugin.",
"why": "The Sibelius Scorch plugin is not compatible with Firefox 18 and above, and is crashing whenever loaded on affected versions of Firefox. ",
"name": "Sibelius Scorch plugin",
"created": "2013-01-14T09:26:47Z"
},
"enabled": true,
"versionRange": [
{
"severity": 1,
"maxVersion": "6.2.0b88",
"minVersion": "0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
]
}
],
"matchFilename": "Scorch\\.plugin",
"id": "28b5baa1-6490-38e2-395f-53fc84aa12df",
"last_modified": 1519390918909
},
{
"schema": 1519390914958,
"blockID": "p1151",
"details": {
"who": "All users who have the QuickTime Plugin for Windows installed.",
"why": "The QuickTime Plugin for Windows has been <a href=\"https://support.apple.com/en-us/HT205771\">discontinued by Apple</a> and has known critical security vulnerabilities. All users are strongly encouraged to remove it or keep it disabled.",
"name": "QuickTime Plugin for Windows",
"created": "2016-04-18T17:41:00Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "*",
"minVersion": "0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 2
}
],
"matchFilename": "npqtplugin\\.dll",
"id": "bb8db302-9579-42d2-ff75-c61500f6a020",
"last_modified": 1519390918887
},
{
"schema": 1519390914958,
"blockID": "p28",
"details": {
"who": "All users of Internet Saving Optimizer for all Mozilla applications.",
"why": "This plugin causes a high volume of Firefox crashes and is considered malware.",
"name": "Internet Saving Optimizer (plugin)",
"created": "2011-03-31T16:28:26Z"
},
"enabled": true,
"versionRange": [
{
"maxVersion": "*",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
]
}
],
"matchFilename": "NPFFAddOn.dll",
"id": "c85a4a9c-d61c-130f-d525-ea36becac235",
"last_modified": 1519390918863
},
{
"schema": 1519390914958,
"blockID": "p456",
"details": {
"who": "All Firefox users who are using old versions of the VLC player plugin.",
"why": "Old versions of the VLC player are known to cause stability problems in Firefox. All users are recommended to update to the latest version of their VLC software.",
"name": "VLC Player plugin 2.0.5 and lower (click-to-play)",
"created": "2013-09-30T14:35:07Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "2.0.5",
"minVersion": "0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "npvlc\\.dll",
"id": "0cfaaefe-88a4-dda4-96bc-110e402ca9d5",
"last_modified": 1519390917137
},
{
"schema": 1519390914958,
"blockID": "p1144",
"details": {
"who": "All users who have these versions of the Java plugin installed.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 8 update 64 to 76 (click-to-play), Windows",
"created": "2016-03-31T16:18:15Z"
},
"enabled": true,
"infoURL": "https://java.com/",
"matchName": "Java\\(TM\\) Platform SE 8 U(6[4-9]|7[0-6])(\\s[^\\d\\._U]|$)",
"versionRange": [
{
"severity": 0,
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "npjp2\\.dll",
"id": "b3c55844-79d2-66dd-0d44-82fb4533307e",
"last_modified": 1519390917115
},
{
"schema": 1519390914958,
"blockID": "p408",
"details": {
"who": "All Firefox users who have affected versions of the QuickTime plugin installed.",
"why": "Old versions of the QuickTime plugin are known to be insecure and cause stability problems. All users are recommended to update to the latest version available. You can check for updates in the <a href=\"http://www.mozilla.org/plugincheck/\">plugin check page</a>.",
"name": "QuickTime Plugin 7.6.5 and lower (click-to-play), Mac OS X",
"created": "2013-06-28T09:52:37Z"
},
"enabled": true,
"versionRange": [
{
"severity": 0,
"maxVersion": "7.6.5",
"minVersion": "0",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "QuickTime Plugin\\.plugin",
"id": "4f39cd0f-976c-1f71-2d9c-2abe1b4706d9",
"last_modified": 1519390917091
},
{
"schema": 1519390914958,
"blockID": "p1059",
"details": {
"who": "All users who have these versions of the Java plugin installed.",
"why": "Old versions of the Java plugin are potentially insecure and unstable. All users are strongly recommended to update on our <a href=\"http://www.mozilla.com/plugincheck/\">plugin check page</a>.",
"name": "Java Plugin 7 update 81 to 90 (click-to-play), Mac OS X",
"created": "2015-12-02T12:37:58Z"
},
"enabled": true,
"infoURL": "https://java.com/",
"versionRange": [
{
"severity": 0,
"maxVersion": "Java 7 Update 90",
"minVersion": "Java 7 Update 81",
"targetApplication": [
{
"guid": "{ec8030f7-c20a-464f-9b0e-13a3a9e97384}",
"maxVersion": "57.0.*",
"minVersion": "0"
}
],
"vulnerabilityStatus": 1
}
],
"matchFilename": "JavaAppletPlugin\\.plugin",
"id": "799c4f10-d75d-30a0-5570-56df6be628e0",
"last_modified": 1519390917067
},